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Tuesday

Session 1 AM: 9 AM to 12:30 PM
Review of History, Gumball, Boolean Operations. 
Developing Block Content: Doors and Windows 

Session 1 PM: 1:30 AM to 5:00 PM
Modeling with History: Villa 

Lands Design, Introduction to Grasshopper

Wednesday

Session 2 AM: 9 AM to 12:30 PM
Organic modeling: Adminstrative Building

Introduction to Grasshopper
Parametric Trusses

Session 2 PM: 1:30 AM to 5:00 PM
Continue modeling Adminstrative Building

Rendering with Flamingo
Start modeling Residential building

Thursday

Session 3 AM: 9 AM to 12:30 PM
Continue Residential building 

Start Mobius 
Terrain to Google Earth

Session 3 PM: 1:30 AM to 5:00 PM
Terrian for lasercut

Layouts and Make2D
Virtual Reality

Friday

Session 4 AM: 9 AM to 12:30 PM
Visual ARQ model 

Session 4 PM: 1:30 AM to 5:00 PM
Visual ARQ model 

Training Schedule
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This page is a revision for Rhino Level1 essential commands to facilitate the modeling process throughout this 
guide. We will cover the Gumball, History and Boolean Operations. 

Revision
Revision

Gumball:

The Gumball command displays the gumball widget on a selected object 
facilitating move, scale, and rotate transformations around the gumball 
origin.

Actions:

1.	 Move by dragging the x,y,or Z arrows
2.	 Scale,  by dragging the square at the end of the arrow

	 hold shift for a uniform Scale
3.	 Rotate by dragging the arc around the X,Y, or Z arrow
4.	 Copy Hold ALT as you move to copy
5.	 Extrude Hold CTRL as you dray the curves.
6.	 Bunny Tail to access menu ball

History:

The History command stores the connection between a command’s input 
geometry and the result so that when the input geometry changes, the result 
updates accordingly.
For example, with History recording and Update turned on, a lofted surface can 
be changed by editing the input curves.

Example:
1.	 In the status bar, click the Record History pane.	
2.	 Use a history-enabled command such as the Loft command to make a surface 

from input curves.
3.	 Edit the input curves.
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Boolean Operations:

The Boolean commands work best on closed surfaces and polysurfaces that 
intersect each other completely.

Boolean2Objects
	 Cycle through possible Boolean operations between two objects.

BooleanDifference
	 Subtract the volume of one set of objects from another.

BooleanIntersection
	 Create a new solid from solids’ intersected volumes.

BooleanSplit
	 Split and close solids at intersections.

BooleanUnion
	 Combine the volumes of one or more objects.

CurveBoolean
	 Trim, split, and join curves based on their overlapping regions.



Intro to rhino in architecture   |  2017	

Robert McNeel and Associates   |  2017	 11Robert McNeel and Associates   |  2017	 11

Setting up the drawings:

1.	 Go to https://www.andersenwindows.com/for-professionals/archi tectur-
al-tools/

2.	 Download 2D elevation of Casement windows as a dwg file.
3.	 Open the file.
4.	 Select a windows to model.
5.	 Move it to 0,0,0.

Create Layers:

1.	 Open the Layer Panel.
2.	 Create new layers called: Frame, Grille.
3.	 Assign each curve to its layer.
4.	 Select Frame and Grille
5.	 Export Selected to a new Document and call it Window_Block.
6.	 Open Window Block.3dm
7.	 Create more layers called: Glass, Trim, Grille, Crown.

Modeling the Window Frame:

1.	 Select the outer frame.
2.	 Under the surface menu click planar curves.
3.	 Split that surface with the inner frame and glass curves.
4.	 Move the glass surface to the glass layer.
5.	 Under the solid menu, extrude surface > straight.
6.	 select the outer frame surface.
7.	 Extrude to 3”.
8.	 Select inner frame, extrude to 1.5”.
9.	 Select the glass, extrude to .5”.
10.	Move the glass from its mid point to inner frame mid point.
11.	Hide the glass and frame layer.

Trimming the Grille:

1.	 On the top view, trim the bottom four rows leaving the top row.
2.	 Make sure the top curves connect as a closed curve.
3.	 Use trim and join to close the curves or use.
4.	 Selced the closd curve.
5.	 Go to surface > Exrude curve > straight.
6.	 Extrude to .25
7.	 Move the solid on top of the Glass.

The aim of this tutorial is to learn how to create usable blocks for windows and doors from manufacturer websites 
like Anderson windows website. These blocks will be inserted as instance blocks in later chapters of this guide.

Outer Frame
Inner Frame
Glass

Chapter 1: Creating Usable Blocks
Chapter 1: creating usable blocks



Intro to rhino in architecture   |  2017	

12										                         Robert McNeel and Associates   |  2017	

Creating the trim:

1.	 Create a box 3pts from the edges of the frame to it’s center.
2.	 Height of the box is 5.5 inches.
3.	 Create another box on the side.
4.	 Scale 1D from the center to stretch the top trim in both sides.
5.	 Rotate (Copy= Yes) from between center to center of the frame.

Mid isocrv

Creating the Shelf:

1.	 Select the bottom trim
2.	 Rotate it 90 degrees
3.	 Move Face to make the shelf longer. (Solid > Solid Edit Tools > Face > Move 

face).

Creating the crown molding:

1.	 Insert Crown_molding.png into the Rhino file.
2.	 Pick a crown you like
3.	 Trace it.
4.	 Scale and orient 3pt to the top of the trim.
5.	 sweep1 using the edge of the trim.
6.	 Cap to create a closed poly surface.

Chapter 1: creating usable blocks
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Assigning Materials:

Render > Current render > Rhino Render.

By Layer:

1.	 In the layer tab there is a material column.
2.	 Click on the material bubble next to layer.
3.	 Change the color and gloss for the trim layer.
4.	 Click on the plus sign to browse the material library.
5.	 Transparent > Glass For the class layer.
6.	 Wood > Cherry for the trim layer.
7.	 Match material for the crown layer.

Texture Mapping:

1.	 Change the mapping for the wood grains.
2.	 Select objects on the trim layer.
3.	 Click on the texture icon from the properties panel.
4.	 Select box texture map.
5.	 Draw the box and accept
6.	 Roate the grains 90 degrees from the texture panel.
7.	 Render

Creating Blocks:

1.	 Use the polysurface filter to select all the polysurfacess in the scene.
2.	 Edit > Block > create block definition.
3.	 Select a base point
4.	 Go to Edit> Block > block manager.
5.	 select your defined block.
6.	 Export to file.

Chapter 1: creating usable blocks
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Doors:

Similar to windows. 
Choose the door that you like.

1.	 Select the outer frame
2.	 Planarsrf
3.	 Select the other two frames and split the surface by it.
4.	 Select the outer frame 
5.	 Extrudesrf = 3” make sure delete input = yes, solid = Yes
6.	 Select the second frame
7.	 Extrudesrf 1.5”

Design the Grille:

1.	 Split the glass with the center line
2.	 Extrude glass .25
3.	 Extrude thread 9”
4.	 Move glass to center of the frame

Simple:
1.	 Extrude the grille grid .25”
2.	 Move on top of the window
3.	 Select the bottom rectangle
4.	 Offsel 2”
5.	 Extrude .25”
6.	 Move vertical on top of the frame
7.	 Chamfer bottom frame
8.	 Draw diagnal line
9.	 Extrude to intersect
10.	split
11.	ChamferEdge

Detailed:

1.	 Draw profile curve
2.	 Copy, rotate, sweep2
3.	 Select all
4.	 Block 
5.	 Export selected to a different file.

Chapter 1: creating usable blocks
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Setting up the plans:

1.	 Open a new inches or meters template.
2.	 Make a layer called pic and 2 sublayers called ground and first
3.	 Type pictureframe and select the ground floor plan
4.	 Type 0 for the first point location.
5.	 With ortho enabled, selects another point to insert the picture.
6.	 Scale the image based on one of the dimensions on the plan
7.	 Do the same for the first floor plan.
8.	 Move the first floor plan verticly using the gumball 3.5m =  3.41inches
9.	  Move both plans to their layers

Drawing the plan:

1.	 Create three layers, Walls, Windows,doors
2.	 The plan has both metric and imperial dimensions.
3.	 trace the plan using your prefered dimensions ignoring the openings 
4.	 Offset the wall to .2m = 7.87inches
5.	 Trace the openings.
6.	 Scale the openings so that the boundry cuts beyond the walls.

The Roof setup:

1.	 Draw a rectangle from one corner to another.
2.	 offset to the outside 1m = 39.3 inches
3.	 Copy the offset in place.
4.	 Move verically 7m = 276 inches
5.	 Select both rectangles
6.	 Invert hide selection
7.	 Explode
8.	 Draw 3 more lines across the top rectangle
9.	 Delete all horizontal curves.
10.	Rebuild all curve to 5pts @ Degree 3  (Edit > Rebuild)

Record History:

1.	 Make sure Record History in always ON.
2.	 Select the top curves and Loft them (Surface > Loft)
3.	 Test to see if the loft works.
4.	 Select the curves and tilt them 10 degrees.
5.	 Select bottom curves and tween them n=20

	 (Curves > tween curve)
6.	 Test to see if history works.

The aim of this tutorial is to learn how to establish the connection between command inputs and the result. It 
will also explore modeling aids, boolean opertations, linked blocks and explore different plugins for Panelings, 
landscape and rendering.

Chapter 2: Modeling With History
Chapter 2: Modeling with history
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1.	 Select all tweened curves
2.	 Project with History to the top lofted surface.
3.	 With the curves already selected, Extrude .5m = 19.6inches
4.	 Select the bottom surface and copy it to the top of the beams.
5.	 Make another copy of the top and hide it.
6.	 Split both top and bottom surfaces with the beam surfaces.
7.	 Delete every other surface
8.	 Join and cap
9.	 show the hidden surface.
10.	Extrudesrf .2m = 7.87inches

The building:

1.	 show the walls layer
2.	 Select the curves and extrude to boundry
3.	 select the bottom of the roof surface as the boundy

Openings - Windows:
1.	 Select all the curves on the wondows layer.
2.	 Move vertically with the gumball to .3m = 11.8inches.
3.	 Extrudecrv to 2m = 78.7inshes.
4.	 Select all extrusions except for the bottom right corner
5.	 copy/paste
6.	 move 3.5m = 137.7inches.

Openings - Corner Windows:
7.	 Solid > Solid Edit tools > Face > Move face
8.	 Select the top surface of the extrusion
9.	 Go to 4views
10.	Hit “alt” to temp disable Osnap
11.	Make sure Ortho in ON
12.	Move the face till it reaches below the roof

Openings - Doors:
1.	 Select all curves on the doors layer
2.	 Extrude all to 2.2m = 86.6inches
3.	 copy/paste
4.	 move 3.5m = 137.7inches.

Chapter 2: Modeling with history
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Boolean Operations:

1.	 Boolean Difference the windows and door from the walls.
2.	 After selecting the boolean difference command.
3.	 select the walls, Enter.
4.	 Go to the layers and right click on the windows and doors layer
5.	 Selects “ select object”
6.	 Enter

Top Floor:

1.	 Hide the walls.
2.	 Select inner wall curve
3.	 copy/move 3.5m = 137.79
4.	 Planarsrf
5.	 ExtrudeSrf bothsides .2m = 7.87inches
6.	 Trace the curves for the openings
7.	 Extrude curve solid, bothsides
8.	 Boolean difference

Windows and Door Blocks:

9.	 File > Insert
10.	Browse to Windows 8,9 &10, 

	 and single & double door.
11.	Make sure Rotate is checked
12.	Embed or Link the blocks
13.	Insert/Copy/rotate into place.

Outdoor Deck:
14.	Trace the outter boundry of the cabin.
15.	 HIde invert selection.
16.	Extrude -.15m -= 5.9inches
17.	Copy move -.3 = 11.8
18.	Repeat 3 times
19.	Draw a small box .5mx.5m = 20inx20in 
20.	Copy to coners
21.	Boolean Union.

Chapter 2: Modeling with history



Intro to rhino in architecture   |  2017	

18										                         Robert McNeel and Associates   |  2017	

Stairs:

1.	 Snap to the edge of the deck.
2.	 Draw one riser and one thread.
3.	 .15m = 5.9inch, .3m = 11.8 inches
4.	 Array Linear
5.	 Join
6.	 Offset curve ( curve > offset) Corners= sharp, Cap = Flat
7.	 Extrude to the curve boundry.
8.	 Copy stairs to the back.

Railings- Grasshopper:

1.	 Curve > curve from object > Dup edge
2.	 Select the edges of the deck for the handrail
3.	 Draw a polyline and join edges
4.	 Open Handrail.gh
5.	 Select the duplicated curves and zoom in to Input curves.
6.	 Select Set multiple curves.

Chapter 2: Modeling with history
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Chapter 2 - Modeling With History
Ground Floor Plan

Chapter 2: Modeling with history
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Chapter 2 - Modeling With History
First Floor Plan

Chapter 2: Modeling with history
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Extrusions:

1.	 Open Admin-start.3dm
2.	 Select the skin curves in “blue” and extrude them to the other side.
3.	 Do the same for the building curve “Pink”
4.	 Extrude the top “pink” curve to the top pink boundry.
5.	 Use makeHole to create the opening in the skin (Solid > solid Edit tools> Holes 

> makehole).
6.	 Extrude the base to 3.5m =137.7 inches
7.	 Mirror to the other side.
8.	 Turn floor and roof layer on.

The aim of this tutorial is to learn how to ease the modeling process with a mix of simple and advanced Rhino 
commands like: Wirecut, Cplane, Patch, CreateUVcrv. Grasshopper will be first introduced to create trusses.

Chapter 3: Advanced Modeling - Part 1
Chapter 3: Advanced Modeling - Part 1

Structure:

1.	 Turn off all layers.
2.	 Turn structure layer on.
3.	 Go to (Solid > Slab)
4.	 Pick the middle line of the rectangle.
5.	 Choose both sides, hieght = .2m = 7.87 inches.
6.	 move from mid point of slab to mid point of the top line.
7.	 copy the rest.
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Columns:

1.	 Select the 4 circles on the bottom.
2.	 Extrude to 24m = 944 inches.
3.	 Draw a line from one end to another
4.	 Scale from center to 21.5 m =  846.5 inches
5.	 Solid > pipe = .3m= 11.8 inches , Cap = round.
6.	 Draw a sphere from the center of each column
7.	 Copy to all columns.
8.	 Boolean Union the sphere with the column.

Light Fixture- Body:

1.	 Select the rectangle Tool.
2.	 Choose from Center in the command line.
3.	 Snap to the end of the piped line
4.	 From the right view, holding down shift, draw a 2.5m =98inches rectangle .
5.	 Rotate the rectangle with gumball to 45 degrees.
6.	 Turn on control points.
7.	 Deform.
8.	 Extrude to 5m = 196.8 inches.

Light Fixture - Frame:

1.	 Under the Cplane tab, select Cplane to object.
2.	 Select the base of the light fixture as the object.
3.	 Use sub selection (Shift + Ctrl) to select the base face.
4.	 DupFace border. (Curve > Curve from object > Dup Face Border)
5.	 Offset the border to the inside .2m =  7.8inches.
6.	 Select both curves and extrude them -.15m = -5.9 inches
7.	 Boolean Union both the body and the frame together.
8.	 Use the Alt key to copy the fixture X5.

Chapter 3: Advanced Modeling - Part 1
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Elevator:

1.	 Turn on the Elevator layer
2.	 Select all curves on the Cplane
3.	 Go to Curves > curve Edit Tools > curve Boolean
4.	 Select inside the polygon to keep, Delete= All used.
5.	 Extrude the Booleans curve to 2.5m = 98.4 inches.
6.	 Go to Solid > Sweet 1 rail
7.	 Select the rail, then the hinges.
8.	 On the Cplanes Tab, Set Cplane by surface.
9.	 Select one face of the elevator
10.	Dup face border
11.	Offset
12.	Repeat for all faces
13.	Split views verticly to see all sides.
14.	Use the split tool to split the glass geometry with the offset curves.
15.	Create a glass layer under the building and move the surfaces to it.

Chapter 3: Advanced Modeling - Part 1
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Chapter 3: Advanced Modeling - Part 1

Trusses - Option 1:
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Chapter 3: Advanced Modeling - Part 1
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4 5

Chapter 3: Advanced Modeling - Part 1



Intro to rhino in architecture   |  2017	

Robert McNeel and Associates   |  2017	 27Robert McNeel and Associates   |  2017	 27

Trusses - Option 2:

Chapter 3: Advanced Modeling - Part 1
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Chapter 3: Advanced Modeling - Part 1



Intro to rhino in architecture   |  2017	

Robert McNeel and Associates   |  2017	 29Robert McNeel and Associates   |  2017	 29

Chapter 3: Advanced Modeling - Part 1

4 65



Intro to rhino in architecture   |  2017	

30										                         Robert McNeel and Associates   |  2017	

Chapter 3: Advanced Modeling - Part 1

Theatre Screen:

1.	 Turn on Screen layer.
2.	 Select Screen
3.	 Duplicate border
4.	 Offset .5m = 19.6 inches to the inside
5.	 Split
6.	 Create a frame layer, move the frame to it.

Ramp:

1.	 Turn on ramp layer under Concrete foundation layer.
2.	 Extrude curves to snap to foundation layer.
3.	 Go to Curves > Curve from Object > CreateUVcrv
4.	 Select one extruded surface
5.	 Draw a diagonal line across the UV curve
6.	 Go to Curves > Curve from Object >ApplyCrv
7.	 Select the diagonal curve then surface to apply onto.
8.	 Do the same for the second extrusion
9.	 loft between both diagonal lines.
10.	Delete side surfaces.
11.	Extrudesrf the ramp -.2 = 7.8 inches
12.	Duplicate Edge bottom sides of the ramp
13.	Extrude .5m= 19.6inches
14.	Offset surface .2m = 7.8 inches.

Stairs:

1.	 Create a new layer and call it stairs.
2.	 In the front view draw the profile curves for the stairs.
3.	 Extrude.
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Chapter 3: Advanced Modeling - Part 1

Organic Terrain:

1.	 Create a new layer called “ Terrain”
2.	 Use control point curve, persistentClode = YES.
3.	 Start drawing circles with random sizes and levels.
4.	 Create a boundry for the terrian.
5.	 Planarsrf
6.	 Turn History ON
7.	 Patch ( Surface > Patch)
8.	 Move curves and Turn on control points for editing.
9.	 Make use of SelU and SelV to select  control points in a row.

Deformable Sphere:

1.	 Under the terrian layer.
2.	 Draw a huge sphere on top of the stairs.
3.	 Rebuild 10x10 @ degree 3 (Edit Rebuild)
4.	 Turn control points on
5.	 Deform 
6.	 Select bottom point 
7.	 setPt in the z direction ( Transform set XYZ Coordinates)
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Pillows and lights:

1.	 Insert Pillows as blocks from the support files.
2.	 Insert Rendl CLoud light as a block
3.	 EditBlock
4.	 Scale
5.	 Array 5
6.	 Rotate each
7.	 Insert Rendl Vidis light as a block
8.	  Edit block
9.	 Add linear light
10.	Array along ramp curve

People and Trees:

1.	 Pick a view you want to render
2.	 Save viewport as a named view
3.	 Add images as picture frames 
4.	 Use Transparency maps “White on Black”

Chapter 3: Advanced Modeling - Part 1
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Chapter 4: Advanced Modeling - Part 2

Chapter 4: Advanced Modeling - Part 2

Intro to Paneling Tools:
Paneling Tools (developed by: Rajaa Issa (rajaa@mcneel.com) facilitates conceptual and detailed design of panel-
ing patterns using NURBS and mesh geometry. 
In this exercise we will panelize  a freeform surface and prepare it for 3D printing.

Open pt-freeform.3dm

Paneling Tools Structure:

1. Create 2D Pattern on 2D Grid:
1.	 Paneling Tools > Create Paneling Grid > Array
2.	 Paneling Tools > Panel from Grid > Panel 2D Grid
3.	 Choose from a number of predefined panels.
4.	 Faces and Edges = YES
5.	 Panel Utilities > Extrude Edges

2.Create 2D Pattern on 3D Surface:
1.	 Paneling Tools > Create Paneling Grid > Surface Domain Number
2.	 Paneling Tools > Panel from Grid > Panel 2D Grid
3.	 Choose from a number of predefined panels.
4.	 Faces and Edges = YES
5.	 Panel Utilities > Extrude Edges

A. POINT ATTRACTOR

1. Create custom 2D variable Pattern on 2D Grid:
1.	 Paneling Tools > Create Paneling Grid > Array
2.	 Paneling Tools > Panel from Grid > Panel custom 2D Variable
3.	 Pattern Method = Mean, Distribution Method = Point Attractor

2.Create custom 2D variableon 3D Surface:
1.	 Paneling Tools > Create Paneling Grid > Surface Domain Number
2.	 Paneling Tools > Panel from Grid > Panel custom 2D Variable
3.	 Pattern Method = Mean, Distribution Method = Point Attractor
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Chapter 4: Advanced Modeling - Part 2

B. CURVE ATTRACTOR

C. BITMAP

D. RANDOM / LIST

Broad musuem, LA Cornell Tech, NY Nike, MIA
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1. Create 3D Pattern on a Freeform Surface:
1.	 Turn the surface layer ON
2.	 Offset surface 1 inch
3.	 Paneling Tools > Create Paneling Grid > Surface Domain Number for both 

surfaces.
4.	 Paneling Tools > Panel from Grid > Panel 3D Grid
5.	 Choose from a number of predefined panels.
6.	 Solid = YES

3.Create custom 3D variable Pattern on 3D Surface:
1.	 Paneling Tools > Create Paneling Grid > Surface Domain Number
2.	 Paneling Tools > Panel from Grid > Panel custom 3D variable
3.	 Select List and Random
4.	 Choose you custom 3d Panel

2.Create custom 3D Pattern on 3D Surface:
1.	 Paneling Tools > Create Paneling Grid > Surface Domain Number
2.	 Paneling Tools > Panel from Grid > Panel custom 3D
3.	 Choose you custom 3d Panel
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Chapter 5:3D Printing

Chapter 5: 3D Printing

Preparing the Rhino model for 3D printing beings early on in the model creation. 
Here are some general steps to successful export Rhino geometry for 3D printing.

You may be 3D printing from to own printer, a corporate printer, or use an online service like 3D Hubs or 
Shapeways. There are other more discreet services that are better for protection of intellectual property.like 
Fathom.

Setting Up the Rhino Model

Units

You can develope the Rhino in whatever units system you prefer to work, However, most all3D printing software 
will import in mm. Scaling at that point is an option, but can be a bit awkward, compared to scaling in Rhino. You 
can change your units in Rhino, and Rhino will provide the conversion. This is done right before export, after the 
rest of the model preparation has been complete. (See below.)

Absolute

Setting up the model is primarily about picking an absolute tolerance for the model that will support the wall 
thickness that you will be exporting. In general, the tolerance in units used when creating new geometry that 
cannot be absolutely accurate. For example, trimming surfaces, doing offsets and Boolean operations usually 
create approximate geometry.

The general rule is:

Printer tolerance x 10 = Absolute Tolerance

      .01 x 10 = .001
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This is located in the Rhino Options dialog, Document Properties, Units. Here 
pick you unit and the absolute tolerance. 

Rhino offers template that are already set up to this absolute tolerance

Chapter 5:3D Printing
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Goal: Closed Polysurface:

The 3D model should be closed polysurface or closed extrusion.  i.e. if you filled it with water, it would not leak. 
As you are modeling, always keep this in mind and check for closure after every surface command. This is the 
reason why most 3D print will fail.

In Rhino, you will create a valid closed polysurface. 
You can check for closed condition in Object Properties Panel.

If your model is not closed use the ShowEdges command, 
Show Naked Edge to find the problem area.

Fixing the opening will take some advance surfacing work.
Patch, EdgeSrf and 2RailSweep are good commands to close 
the model.

Check the Model:

Look for any bad objects that may prevent good STL from being created.
1.	 SelBad will identify the bad surface or object to be extracted.
2.	 ExtractBadSurface will identify and remove it from the polysuface for rebuild-

ing.
3.	 Rejoin and verify for valid and closed polysurface
4.	 Look for the best orientation for export. Rotate the model if required.

This orientation will give the model the most stability and avoid most undercuts.
The undercut will be printed in the support material. This may be PVA or similar 
and dissolve in water. But it will add significantly to the print time.  

Preferred orientation is shown in 
purple.The red surface represent the 

glass plate in the 3D printer.

Chapter 5:3D Printing
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Converting Model to MM

1.	 SaveAs model to a different name, with a 3DP in the name to desig-
nate it will be used for 3D pprinting.

2.	 In the new model, go to Rhino Options dialog, Document Properties, 
Units.

3.	 Pick Model Units: Millimaters
4.	 Rhino will offer the conversion: Pick Yes

Now your model is in the MM unit and ready to export.

5.	 Select all geometry.
6.	 File -> ExportSelected -> STL
7.	 Adjust mesh settings (below)
8.	 In the STL Export Options dialog box, set the file type as Binary and 

click OK.
9.	 Open Mesh Model in Rhino

Mesh Settings

Goal: 

Create a mesh that is dense enough to give you a great looking 3D print, but 
that does not exceed the polygon count for the 3D printing software. That is 
usually less than 600,000 polygons.

Simple controls will give you a slider bar to select the density.
If Detailed controls is used set set all the mesh setting to 0. And change the 
following:

•	 Minimum Initial Grid Quads: 16
•	 Refine Mesh: yes
•	 Jagged Seams: no
•	 Simple Planes: yes
•	 Maximum Distance edge to Surface: This is calculated by setting to a value 

less that half of the printer’s resolution. For models in millimeter, use 0.01.

Chapter 5:3D Printing
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Chapter 5:3D Printing

Check Mesh
Check for success next. 
Open the STL or other file back in Rhino.
Object Properties should report Closed Mesh.

Non Manifold Edges
If multiple faces in a Mesh share an edge, this can cause an invalid mesh. 
ShowEdge has an option to show Non Manifold edges, as well as naked edges.
DeleteMeshFace will help delete the extra face, and FIllMesh hole can then be 
used to close the mesh.

Close Openings
It it is open, you can fill the holes with the
‘FillHole and FillHoles. 
Rhino also has a MeshRepair commands with is a wizard to help repair mesh.

Too Many Polygons
ReduceMesh command to bring the polygon count down below 600,000.

Unify Mesh Normals
Your normal directions on the mesh faces many be pointing in and out.
This can be seen in the shaded preview as having holes in the mesh.
Set all the normals to a positive direction with the UnifyMesh Normals

Now save and import into your 3D print software.
For example, to print to the Ultimaker, we use the CURA software. 
Search at Web Resources for 3D Printing
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Chapter 6: Graphical Representation

In this exercise we will access a wide range of graphical representation from setting up the camera, its angle and 
field of view to manipulating display modes. These additional display options include shadows, edge thickness by 
type, and lighting control.

Chapter 6: Graphical Representation

Setting up the view:

	 The Camera:
1.	 Click on the arrow next to the viewport name.
2.	 Set camera > Show Camera, (F6) for shortcut.
3.	 Navigate to other viewports and adjust the camera location and view angle.

	
	 Location:

1.	 Place the camera and the target point on the floor.
2.	 In the Z direction of the gumball type 1.7 to move it to eye level.
3.	 Navigate in different viewports using the camera viewpoint and Target point.

	

1.	 The camera viewpoint.
2.	 The camera location can be 

used to move the whole camera 
widget.

3.	 The roll control tilts the camera.
4.	 The target point.
5.	 The field of view/lens angle.

	
	 Moving the camera:

Visit https://wiki.mcneel.com/rhino/cameramanipulation to learn more about 
camera manipulation, movements and shortcuts.
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Field of View:
1.	 Under the properties tab > set the projection to:

	 (perspective, two point perspective, or parallel).
2.	 Field of view (Focal Length)  > adjust the lens length:

•	 < 21mm: Super wide-angle lens,
•	 21-35mm: Wide-angle lens
•	 35-70mm: Standard / Normal lens
•	 70-135mm: Standard Telephoto
•	 135-300mm (or more): Telephoto

3.	 You have options to accurately place your camera’s location and target.

*Note: The smaller the focal length the wider the field of view.

Take a look at different Focal Lengths for the same named view:

15mm 22mm 35mm 50mm

Chapter 6: Graphical Representation
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	 Named View:
1.	 Once you are happy with the view.
2.	 Right click on the properties panel tab
3.	 Choose named views.
4.	 Open named views tabs > click on the save button to name and save your view.

* Note: Rhino has unlimited number of cameras and named views.

	 Safe Frame:
The safe frame shows the area of the viewport that will be rendered in the 
active viewport.

1.	 Tools > Options > Renderings > Safe frame
2.	 Live Area: Shows the size of the rendered view as a yellow frame in the view-

port.
3.	 Action Area: Shows a user-specified action area frame in blue.
4.	 Title Area: Shows a user-specified title area frame in orange.
5.	 Fields: Divides the live area into a 4-by-3 grid, commonly used for production 

rendering and film work.

* Note: Safe frame is useful when rendering resolution is set differently form the 
active viewport.

With Safe Frame Without Safe Frame

Chapter 6: Graphical Representation
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Chapter 6: Graphical Representation

Display Modes:

Rhino 5 has many advanced display options that can be configured to create more advanced, 
realtime display modes. These display options include shadows, edge thickness by type, and 
lighting control and can be configured according to your needs.

1.	 Unzip the Displaymodes folder 
2.	 Go to Options > Rhino Options > Display modes > Import
3.	 Browse to the folder and select each mode one at a time.
4.	 Click ok to close Rhino Options
5.	 Click on the Arrow next to the viewport title to see the loaded custom display modes.
6.	 SetObjectDisplayMode > To mix different display modes in one scene.
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Clipping Plane:

The ClippingPlane command creates a clipping plane object that represents a plane for visibly 
clipping away geometry in a specific viewport.

1.	 Under the view menu > Clipping Plane.
2.	 in the front view draw the clipping plane
3.	 Under the properties menu > click on the clipping plane icon
4.	 Set the view and direction
5.	 Draw two more clipping plane top and Right.
6.	 Show/hide them in different views
7.	 Use different display modes to view them.

One Clipping Plane Three Clipping Planes

Chapter 6: Graphical Representation
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Chapter 7: Complex Geometry - Rhino

Chapter 7: Complex Geometry - Rhino

This excersice create a mobius geometry in two similar ways once with Rhino and the other with grasshopper. It 
uses simple commands to create complex geometry.

Get started
1.	 Open file Mobius.3dm.
2.	 Make the Mobius Curve layer current.
3.	 Add a point on the long side of the curve as shown. 
4.	 Group the curve and the point.

Array the curve and point
1.	 Select the grouped curve and point.
2.	 ArrayPolar in front view from the closest quad of the circle.
3.	 Set the Number of items to 8.
4.	 Set the Angle to fill to 360.
5.	 Move each curve in sequence to layers 0, 45, 90, 135, 180, 225, 270, 315.
6.	 Rotate each layer based on its name from the center of the large circle on the 

plan layer.
7.	 Ungroup all.

Loft the curves to create a surface:
1.	 Loft all the Mobius curves together.
2.	 Adjust the seams to snap to the points.
3.	 In loft options choose
4.	 Style <Normal>
5.	 Check <closed curve>
6.	 Add the loft result to a layer called “initial geometry” 
7.	 Hide all the layers except “initial geometry”
8.	 Rebuild this to:
•	 Point count: <U: 100>, <V: 35-40>
•	 Options: check Delete input



Intro to rhino in architecture   |  2017	

50										                         Robert McNeel and Associates   |  2017	

Extract Wireframe:

1.	 Make a new layer called Wireframe and make it current
2.	 ExtractWireframe and hide the initial geometry.
3.	 Make two new layers and name them one “Verticals” and the other “Horizontals”
4.	 In the top view select all the horizontal lines by dragging the cursor to open a window from right 

to left between two vertical curves
5.	 Move those selected curves to the horizontal layer
6.	 Hide the Horizontal layer 
7.	 Select all the vertical curves and move them the vertical layer
8.	 Show both vertical and horizontal layers and change their colors.

Creating Surfaces:

1.	 Hide the horizontals and select all the verticals
2.	 Use planarsrf to create planes from these curves
3.	 Select all and Offset:  
•	 Both directions <.1m>
•	 Solid <Yes>
•	 Show the initial geometry

Boolean Operation for the Verticals:

1.	 Select the initial geometry and offsetsrf
2.	 Flip Direction to the inside
3.	 Distance <.2m>
4.	 Solid <No>
5.	 Move the offset surface to another layer and hide the initial geometry.
6.	 Boolean Difference the planarsrf from the geometry

Chapter 7: Complex Geometry - Rhino
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Chapter 7: Complex Geometry - Rhino

The Horizontals:

1.	 Hide the verticals and select the curves on the horizontal layer
2.	 Extrude them: Both directions <.1m>
3.	 Extrude the horizontal surfaces:
4.	 Both directions <.2m>
5.	 Solid <Yes>
6.	 Show both horizontals and verticals layers

Creating the floors:

1.	 Hide everything except the initial geometry
2.	 Create a new layer called “floors” and make it current
3.	 In the front view select the geometry and use the contour command”Select a 

point that is parallel to the base of the geometry
4.	 Select a direction perpendicular to the geometry
5.	 Type distance <3m> between floors.
6.	 With the curves selected use planarsrf to create the floors.
7.	 Select the planar surfaces then extrudesrf:  Both Direction <.1>
8.	 Solid <Yes>
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Chapter 7: Complex Geometry - Rhino

Render:

1.	 Show Verticals and horizontals layers
2.	 Change display to Rendered view 
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Chapter 8: Complex Geometry - Grasshopper

Chapter 8: Complex Geometry - Grasshopper and 
LunchBox
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Chapter 8: Complex Geometry - Grasshopper
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Chapter 8: Complex Geometry - Grasshopper
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Chapter 8: Complex Geometry - Grasshopper
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Chapter 9: Fabrication - Part 1
Chapter 9: Fabrication - Part 1

In this exercise, we will Lands design to generate topography from Google Earth. Lands performs a scan of 
the elevation with respects to sea level of the terrain surface visible on Google Earth window and generates a 
representation based on section curves. hese 3d curves can be used in the Lands terrain modeling functions so 
that a true surface can be generated using Google Earth, and cuts and fills, and other earthworks can be carried 
out.

Selecting the Site:

1.	 Open Rhino site.kmz
2.	 Zoom into the site

Scanning the site from Google Earth into Rhino:

1.	 Open Rhino.
2.	 Go the Import Google Earth elevation data icon under lands design toolbar.
3.	 Wait for Lands to scan the data in the background.

Create Layers:

1.	 Create 3 layers: Curves, mesh and surface.
2.	 Assign the mesh to the mesh layer and curves to the curve layer.
3.	 Draw a rectangle around the site.
4.	 Scale everything to match the dimensions on your model.
5.	 Trim the curves based on the site boundary.
6.	 Select the curves
7.	 Rebuild with the same number of point but with degree 3.
8.	 Loft
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Chapter 9: Fabrication - Part 1

Creating the surface boundary in Rhino:

1.	 Duplicate the border of the lofted surface
2.	 Extrude -5 inches
3.	 In the front view draw a line across the terrain with a distance of 1.25inches 

(which is the thickness of the terrain in the physical model).
4.	 Trim the extrusion with thi sline
5.	 Soli > Cap planar holes.
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Chapter 10: Fabrication - Part 2

In this exercise, we will generate the contour curves from a topo surface  to be cut by the laser cutter. The cut 
pieces are stacked into the 3D site model, and the buildings and other details are added. 

Getting Started:

We will break this down into 3 Major Steps:
1.	 The Site Prep
2.	 Contouring in Grasshopper
3.	 Baking Curves to Rhino

The Site Prep:

1.	 Open the Site_cut.3dm.

The Site is a closed polysurface, whose sides have been lofted and joined into a 
closed polysurface. 

2.	 Turn on layers  2 Planar crv, 3 Curves to Extrude, 4 Extrusions.

3.	 Curves on the Curves to Extrude layer, were already extruded into the solid 
extrusions

4.	 Confirm locations of Extrusions. They intersect the topo polysurface.
5.	 Pick Solid -> BooleanDifference
6.	 Select surfaces or polysurfaces to subtract from: Pick the topo.
7.	 Press Enter to continue:
8.	 Select surfaces or polysurfaces to subtract with ( DeleteInput=Yes ):Pick the 

Extrusion
9.	 Press Enter

Chapter 10: Fabrication - Part 2
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Contouring in Grasshopper
1.	 Type Grasshopper. (http://www.grasshopper3d.com/ )
2.	 In Grasshopper, open the definition Contours2.GH.
3.	 Highlight the Geometry parameter, right click.

4.	 Right click on the Geometry parameter, and pick Set one Geometry.

5.	 Pick on the topo polysurface and Enter.

Contour curves are cut, dimensioned and labeled. But they are not part of Rhino 
yet.

6.	 Set the thickness to the height of the media (paper/cardboard/form) that will 
be cut with the laser cutter.

7.	 Curves are being previewed on the Rhino screen, but they are not part of 
Rhino. 

Chapter 10: Fabrication  - Part 2
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Baking Curves to Rhino:

1.	 Right click on the Join, Tag, and Dimension components. 

2.	 Bake the Tag Text to the 6 Laser Cut Text layer.
3.	 Bake the Dimensions  to the 6 Laser Cut Text layer.
4.	 Bake the Join curves to the 5 Laser Curves layer
5.	 Turn off the Grasshopper preview
6.	 Arrange the curves and prepare them to send them to the laser cutter.

Chapter 10: Fabrication  - Part 2
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Chapter 11: Layouts

A layout in Rhino is the full size representation of the sheet or paper that will be sent to the printer, plotter or
virtual printer, like a PDF creator. You can add a layout or multiple layouts to any Rhino model.

Visit: for more details: https://wiki.mcneel.com/rhino/layouts5

Chapter 11: Layouts

In this tutorial, we will:
1.	 Setup a layout with two details, each at a different scale.
2.	 Turn certain layers off in one detail and leave it visible in the other.
3.	 Arrange the details on the title block, add title block labels, and include a raster 

image in the title block.
4.	 Add dimension and annotations that are appropriately sized for each detail 

using annotation scaling.
5.	 Set color and print weight to layers in one detail and not the other.
6.	  Print the layout to PDF.

Start a new layout:

Add details:

Setting up the scale:
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Setting-Up a Model to Use Annotation Scale:

View detail settings:

Adding a Logo to the Title Block

Chapter 11: Layouts
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Chapter 11: Layouts
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Chapter 12: Visualization in Google Earth

In this Tutorial we will look at tools that allow you to anchor your model to a specific location on the earth. The 
idea is to export any Rhino model to a .KML or .KMZ file that can then be posted on a website, or emailed to 
someone so they can view the model in Google Earth.

Chapter 12: Visualization in Google earth

Setting up Google Earth file:

1.	 Under Tools > options change Lat/Long to Decimal degree.

Finding the Latitude and Logitude:

1.	 Open Rhino site.kmz in Google earth.
2.	 Go to the pin and right click on it.
3.	 Write down or cope both latitude and longitude.
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Chapter 12: Visualization in Google earth

Setting up Latitude and Longitude in Rhino:

Open Rhino model

1.	 Type EarthAnchorPoint
2.	 Type in Latitude and longitude from Google Earth.
3.	 Select a point on the model that corresponds with the longitude and latitude
4.	 Select North and east direction.

Opening Rhino file in Google Earth:

1.	 Save the Rhino file as .kmz file.
2.	 Open it in Google Earth.



Intro to rhino in architecture   |  2017	

Robert McNeel and Associates   |  2017	 69Robert McNeel and Associates   |  2017	 69

Chapter 13: Virtual Reality

Modelo a design management platform. It Powers your design process with all the tools you need to communicate 
your vision and collect design feedback. Modelo Communicates the power of your vision with animated 
walkthroughs, powerful 3D presentations, 360° panoramas, and immersive VR experiences.

Chapter 13: Virtual reality

Getting Started:

1.	 Open the Modelo shared Project ( Xerox2Modelo).
2.	 Download Modelo App on your phone.

On the Website:

1.	 Select settings on the Modelo navbar
2.	 Check Architects Effect
3.	 Go to the Material tab and change the sky.
4.	 Click the update button.
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Chapter 13: Virtual reality

Named Views:

1.	 Selects the comment icon on the navbar.
2.	 play all slides.

Create Walkthoughs:

1.	 Select settings on the Modelo navbar
2.	 Check Architects Effect
3.	 Go to the Material tab and change the sky.
4.	 Click the update button.

Virtual Reality:

1.	 Open Modelo app on your phone
2.	 Navigate to Xerox model
3.	 Wear your Google cardboard and walk through the named views.

Note: The mobile app does not support web walkthroughs. Modelo can only 
navigate through named views.
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Chapter 14: Visual ARQ
Chapter 14 Visual ARQ

Introducing Flexible BIM:
VisualARQ enhances Rhino by adding powerful associative object styling and dynamic documentation tools
which adapt to fit your workflow.
For more information visit: http://www.visualarq.com

Freeform modelling

Freeform modelling Powered by Rhino 

 Convert any freeform geometry into an informed 
object with VisualARQ.

Grasshopper for BIM

Define your workflow with the VisualARQ Grasshopper 
Components. 

 Automate object and object style creation through 
visual programming.

Powerful documentation tools

Dynamic and precise documentation always 
available from the VisualARQ 3d model
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Chapter 14 Visual ARQ

Setting Up Levels:

1. Open the level manager. (from the Tools toolbar or typing 
“_vaLevels” in the command line). The Level manager dialog 
box is divided in two parts:
    a. A toolbar line with the following options: New Building , 
New Level  and Cut Plane status Cut Plane Off.
    b. The list of buildings and levels and their properties: 
CPlane (Construction plane), On/Off display status, Locked/
Unlocked status, Elevation value and Top/Bottom offset val-
ues.
2. Click on the building icon   to create a building.
3. Select the building from the list and click on the Level icon  
to create new levels.
4. Create your levels with and elevation values.

Defining Walls

1. Open the wall styles dialog: Before you start 
drawing walls in the model, create the wall styles 
needed in the Wall styles dialog box. You can open 
it with the _vaWallStyles command by right-clicking 
on the wall icon, in the objects toolbar, or from the 
drop-down menu: Wall > Wall Styles.

2. Create a new style: Press the New Style... but-
ton and follow the steps of the wall style wizard to 
define the new style parameters

Notes for Visual ARQ:
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Chapter 14 Visual ARQ

Notes for Visual ARQ:

Doors and Windows:

Doors:
1. Run the _vaDoor command   or click on the door icon in the Object toolbar. The 
door insert dialog box will appear with the list of existing door styles.
2. Select the Door style you wish to insert and the basic insert options

Windows:
1.. Run the _vaWindow command  or click on the window icon in the Object toolbar. 
The window insert dialog box will appear, with the list of existing window styles.
2. Select the window style you wish to insert and the basic insert options

Styles:
1. Open the Window Styles dialog: Use the _vaWindowStyles command to create the 
new style “newWin1”.
2. Click on the New Style... button to open the window style wizard
Follow the steps of the window style wizard
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Chapter 14 Visual ARQ

Stairs:

1. Run the _vaStair command  or click on the Stair icon in the VisualARQ Objects tool-
bar. The stair insert dialog box will appear with the list of existing stair styles.
Select the Stair style you wish to insert and the basic insert options

2. Specify the stair start insert point in the model,

3. To edit the stairs: click on VisualARQ properties in the Rhino properties dialog box: 
Select the stair and int the VisualARQ properties in the Rhino properties dialog box 
change the current style to the new style you have created. Change the height (to 
3m), the stair step count (to 16) and the tread dimension (to 0.32m).




